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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent damage to 
property. The notices referring to your personal safety are highlighted in the manual by a safety alert symbol, notices referring 
only to property damage have no safety alert symbol. These notices shown below are graded according to the degree of 
danger. 

 DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

 

 WARNING 
indicates that death or severe personal injury may result if proper precautions are not taken. 

 

 CAUTION 
with a safety alert symbol, indicates that minor personal injury can result if proper precautions are not taken. 

 

 CAUTION 
without a safety alert symbol, indicates that property damage can result if proper precautions are not taken. 

 

 NOTICE 
indicates that an unintended result or situation can occur if the relevant information is not taken into account. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will be used. A 
notice warning of injury to persons with a safety alert symbol may also include a warning relating to property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific task in 
accordance with the relevant documentation, in particular its warning notices and safety instructions. Qualified personnel are 
those who, based on their training and experience, are capable of identifying risks and avoiding potential hazards when working 
with these products/systems. 

Proper use of Siemens products 
Note the following: 

 WARNING 
Siemens products may only be used for the applications described in the catalog and in the relevant technical documentation. 
If products and components from other manufacturers are used, these must be recommended or approved by Siemens. 
Proper transport, storage, installation, assembly, commissioning, operation and maintenance are required to ensure that the 
products operate safely and without any problems. The permissible ambient conditions must be complied with. The information 
in the relevant documentation must be observed. 

Trademarks 
All names identified by ® are registered trademarks of Siemens AG. The remaining trademarks in this publication may be 
trademarks whose use by third parties for their own purposes could violate the rights of the owner. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software described. Since 
variance cannot be precluded entirely, we cannot guarantee full consistency. However, the information in this publication is 
reviewed regularly and any necessary corrections are included in subsequent editions. 
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1 Product Overview 

1.1 Introduction to the Automation License Manager 

The Automation License Manager is a product of Siemens AG Industry Sector. It is used to 
manage license keys (the technical form of licenses). 

Software products requiring license keys automatically report this requirement to the Automation 
License Manager. When the Automation License Manager finds a valid license key for this 
software, the software can be used in conformity with the end user license agreement. 

Definition of Terms 
The following table explains important terms used in context with the Automation License Manager. 

 
Term Description 
Software A product installed on hardware and used to process data. 
Hardware Computer (PC), device or module on which software runs. 
License A license provides the right to use products. This right takes the form of a 

• CoL (Certificate of License) and  
• License key. 

CoL (Certificate of 
License) 

The CoL is a proof of the license. The product may only be used by the owner of the 
license or an authorized person.  

License key The license key is the "technical form" of the license ("electronic license stamp").  

Storage Locations for License Keys 
You can store license keys on storage media such as license key data carriers, on removable 
drives (but not on CD, CDRW) or USB memory sticks. 

License keys can be located locally on your own computer as well as on a network computer. 
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1.2 Function Overview 

You can execute the following functions with the Automation License Manager: 
 
Function Description 
Management of license keys All functions required for managing license keys 
Transferring license keys Moving license keys between storage locations (for example 

computers, USB memory sticks, folders…) 
Displaying license keys Display detailed information of license keys (for example, validity, 

status, etc.) 
Saving license keys Storing license keys on a local or network computer. 
Checking license keys Determining the status of license keys (for example, OK, used, 

etc.) 
Determining and displaying required 
license keys 

Comparing existing and required license keys 

Checking out license keys License keys are temporarily transferred from a server for use on 
a connected computer. 

Checking in license keys License keys are returned to the server from a connected 
computer. 

Logging actions involving license keys Logging license key-specific actions on a computer 
Blocking of external accesses to license 
keys 

Blocking of external accesses when SIMATIC Logon is not 
available 

Access protection support for license keys When SIMATIC Logon is available on a computer, the 
Automation License Manager can be used to activate access 
protection for license keys. 

 
 Note 

To support access protection for license keys, certain requirements must be met. Refer to "Access 
Protection via SIMATIC Logon Role Management" for the requirements. 

 

Calling the Online Help  

The online help for the Automation License Manager provides you will all necessary information on 
the functionality and operation of license keys. 

After starting the Automation License Manager, you can access the online help via the following: 

• F1 button or 

• Menu command Help > Help on License Manager. 
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1.3 Licenses in the Automation License Manager 

The standard license types and license types listed below are available: 
 
Standard License Types Description 
Single Use of the software with this license is permitted on any one computer. The type 

of usage is defined by the certificate of license. 
Floating Use of the software with this license includes right of use for simultaneous 

usage. The software can be installed at multiple locations. 
Master Use of the software is unrestricted with this license. 
Upgrade Before an upgrade can be used, the system status may need to meet certain 

requirements: 
• Using an upgrade license, a license of an older version can be converted to 

a newer version. 
• An upgrade may become necessary, for example, when the configuration 

limits have to be expanded. 

 
License Types Description 
Unlimited Use of the software with this license is unlimited. 
Count relevant Use of the software with this license is limited to: 

• The number of tags named in the contract. 
Countable Objects The use of the software with this license is restricted to: 

• The number of objects named in the contract. 
Rental  The use of the software with this license is restricted to: 

• The number of operating hours named in the contract.  
• The number of days from first use named in the contract. 
• The expiration date named in the contract.  
Note: You can see brief information on the time left on the rental license in the 
information area of the task bar. 

Trial The use of the software with this license is restricted to: 
• A validity period, for example, a maximum of 14 days. 
• A certain number of days from first usage 
• Use for tests and validation (disclaimer of warranty). 

Demo The use of the software with this license is restricted to: 
• The number of operating hours named in the contract.  
• The number of days from first use named in the contract. 
• The expiration date named in the contract. 
Note: You can see brief information on the time left on the demo license in the 
information area of the task bar. 
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Missing license keys  
License keys that are required by software but are not available in a "valid" form on the network are 
known as missing license keys. 

Note that not all computers connected to the network will be searched, but only those computers 
added to the "search list" in the Automation License Manager.  

You set the computers to be searched in the network with the menu command File > Settings > 
Favorites. 
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1.4 Scope of Delivery 

Installation Software 
You can find the Automation License Manager on the installation medium of a software product 
requiring a license key (a CD-ROM, for example). 

Components of the Automation License Manager 
 
Component Description Must be installed Can be installed 
Automation 
License Manager 

Contains the user interface for the 
Automation License Manager with all 
secondary services. 

X  

Plug-in Contains additional custom product features 
for the Automation License Manager. 

 X 

 

 
 Note 

The Automation License Manager itself does not require a license key.  
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2 Installation 

2.1 Installation Requirements 

Hardware 
For the hardware requirements for using the Automation License Manager, please refer to the 
readme file that ships with this version: 

 
 Note 

You start the supplied readme file after installation of the Automation License Manager with Start > 
Programs > Siemens Automation > Documentation > Readmes. Now select the readme file in 
your preferred language and then the Automation License Manager. 

 

Operating system 
The Automation License Manager is a Windows program. You will find the approved operating 
systems for this version of the Automation License Manager on the supplied readme file  

 
 Note 

You start the supplied Readme file after installation of the Automation License Manager with Start 
> Programs > Siemens Automation > Documentation > Readmes. Now select the readme file 
in your preferred language and then the Automation License Manager. 

 

• The software is compatible with all language versions of the supported operating systems. 

Product-Specific PlugIns for Software Products and Components 
 

 Notice 
The Automation License Manager requires product-specific PlugIns for managing the license keys 
of some software products and components. These PlugIns are always delivered with the project 
when required and installed with their own setup. 
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2.2 Installing the Automation License Manager 

The Automation License Manager is installed via a setup program that guides you step by step 
through the installation process. You can find the installation software for the Automation License 
Manager on the product CD.  

The software components included with the Automation License Manager are listed in "Scope of 
Delivery". 

Preparatory Steps 
Before you can start the installation, you must first start the operating system, see also "Installation 
Requirements".  

• To install the Automation License Manager, connect the data carrier that holds the software 
with your programming device or PC.  

• You do not require an external data storage medium if the software to be installed is already on 
the hard disk of the programming device or PC. 

 
 Note 

Close all programs before starting the installation. 

 

Starting the Installation Program  
Procedure:  

1. Double-click the "Setup.exe" file to start the setup program for the Automation License 
Manager. 

2. Follow the instructions provided by the installation program.  

3. The completion of the installation process is reported in the "Automation License Manager 
Setup" dialog. Click "Finish" to exit the setup program. 

 
 Notes 

• The program guides you step by step through the entire installation process.  

• During the installation, you are prompted to answer questions and make selections in dialog 
boxes. Choose the settings that are suitable for your requirements. 

• You can return to the previous step or advance to the next step at any time.  
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2.3 Uninstalling the Automation License Manager 

Procedure for Uninstalling the Automation License Manager: 
1. Open the Control Panel by selecting Start > Settings > Control Panel on the Start menu of 

your computer:  

2. Open "Software" in the detailed view. 

3. In the list of installed software, select "Automation License Manager". 

4. Click "Remove". 

5. Click "Yes" to confirm the uninstallation. 

6. Click "OK" once the programs have been successfully removed.  

Result: the Automation License Manager has been uninstalled. 

2.4 Installing PlugIns 

Product-Specific PlugIns 
 

 Note 
The Automation License Manager requires product-specific PlugIns for managing the license keys 
of some applications and components. These PlugIns are supplied with the product if they are not 
already available to you. 

 

PlugIns are installed using a product-specific setup program. Follow the relevant instructions in the 
setup program. 
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2.5 Upgrade of Licenses 

License Upgrades 
To use a new or enhanced software version, you will have to upgrade an existing license key to a 
new license key. 

 
 Note 

Note that you must store the "old" license key along with the upgrade itself on the hard disk of the 
computer where the upgrade is to be performed. 

 

 
 Note 

Note that upgrade license keys cannot be installed during the setup program. 

 

Requirements 
To upgrade a license key or an "old authorization", you need: 

• From the software version being upgraded 

- The CoL (Certificate of License) and the license key  

 or 

- An "old authorization" on an authorization disk. 

• From the target version  

- The CoL and the upgrade license key  

      or 

- The upgrade authorization on an authorization disk 

• The license keys or authorizations must be available on the local computer. 

- If the upgrade target is a license key, it can be available on the following storage locations: 
license key data carrier or authorization disk, drive or USB memory stick. 

 
 Note 

For performance reasons, you should store both the "old" authorization and the "old" license key 
with the upgrade itself on a local drive of your computer. 

- If the upgrade target is an authorization: only on authorization disk. 
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Performing a License Upgrade 
The upgrade license key must be available in the access area of the Automation License 
Managers. For this purpose you will have to connec the license key data carrier with your 
computer. 

 

To upgrade a license key, proceed as follows: 

1. Select the View > Management menu command. 

2. In the navigation area, select the location of the license key for which the upgrade is to be 
performed. 

3. In the object area, select the license key to be upgraded. 

4. Select the License Key > Upgrade menu command. 

- If there is only one possibility for an upgrade, it is performed without further messages and 
prompts.  

- If there are several possibilities for upgrading, the "License Key Upgrade" dialog  opens.  

- Select the upgrade to be performed and click on the "Upgrade" button. 

 
 Note 

Note that authorizations are no longer supported on 64-bit operating systems. 
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2.6 Notes on Use of Older Software Versions 

Software Products that can be activated with License Keys 
Software products that can be activated for operation with license keys can also use newer 
license keys. The following applies to these products: 

• "Newer" versions of license keys can always be used to operate different software versions.  

• It is not necessary to downgrade a license key to use "older" versions. 

 
 Note 

You can recognize a license key in the Automation License Manager in the "Management" view by 
its 20-digit license number.  

 

Software products that can be activated with "old authorizations" 
Authorization is required for software products that are activated with authorizations. These 
software products cannot be operated with a license key. License keys for later versions can only 
be used for software products that use a license key. 

An upgrade of an "old authorization" is described in the online help for the Automation License 
Manager in "Upgrade of Licenses". 

 
 Note 

You can recognize an authorization in the Automation License Manager in the "Management" view 
by its 10-digit license number.  
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2.7 Notes on Optimizing Hard Disks 

Optimizing Hard Disks 
When license keys are transferred, clusters are created on the drive (data carrier or hard disk) that 
are labeled as "bad" by some utilities. 

 
 Caution 

Do not attempt to correct such "bad" clusters. Correcting them will destroy the license keys. 

 

If you use an optimization program that is capable of moving fixed blocks, you should first transfer 
the license keys from the hard disk to a license key data carrier before using this option. 

If a backup of your hard disk contains copies of license keys, there is the danger that restoring the 
disk from a backup will overwrite the currently valid license keys and destroy them. To avoid the 
risk of losing license keys in this way, it is strongly recommended to either remove all license keys 
before making the backup or to exclude them from the backup at the start. 

Do not forget to remove the license keys before formatting, compressing or restoring your hard disk 
or installing a new operating system. 

 

  
Notice 
The files used to store the license keys can be destroyed by defragmentation programs that move 
fixed blocks. Recommendation: Always exclude the license keys from the procedure before using 
defragmentation programs. 

 

Excluding License Keys from Procedures 
You have the option to exclude certain license keys or authorizations from procedures: 

• By transferring all license keys to the corresponding license key data carrier. 

• By transferring all authorizations to the corresponding authorization disk. 
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3 Working with the Automation License Manager 

3.1 User Interface 

3.1.1 User Interface of the Automation License Manager 

The user interface of the Automation License Manager has the following structure: 

  

1. Title Bar: 
Contains the window title "Automation License Manager" and the icons for controlling the 
window. 

2. Menu Bar: 
Contains all menus that are available in the Automation License Manager. 

3. Toolbar: 
Contains icons for fast execution of frequently used commands plus the currently selected 
view, here "License keys".  

4. Work Area: 
Contains the navigation area on the left (shown in white above) and the associated object area 
on the right.  

5. Status Bar: 
Located at the bottom edge of the application and contains seven fields for outputting status 
information. 

The displayed information is dependent on the currently selected view and the objects selected in 
the navigation area. 
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Navigation Area 
You can find the following objects in the navigation area on the left: 

 
View Objects in the Navigation Area 
Management Here you will see all the objects you can manage, such as My Computer, network 

computers, folders configured in the Automation License Manager, and license key 
folders. 

Find Here you can select the following search options: Search term, Product, Storage location, 
Standard license type, License type, Status, Used by 

Log Here you can select the corresponding computer as well as different filter criteria. 

Object Area 
Individual objects are displayed in the object area on the right according to: 

• The view set in the Automation License Manager 

• The object selected in the navigation area 

The object area consists of: 

 
Area Description 
Title The title enables the user to see the contents of the current view at a glance. Large icons 

helpsto quickly identify the respective folder.  
Data area The data area shows all the elements within the folder selected in the navigation area. 

 
 Note 

When there are no objects for display in the object area, a corresponding note is shown instead of 
objects. 
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3.1.2 Table Columns in the Object Area 

When you open the Automation License Manager, you see the navigation area on the left and the 
associated object area on the right. According to the displayed object, you will see the 
corresponding information for: 

• License Keys or 

• Software. 

The "License keys" view displays the license keys available on the selected drive along with the 
following related data in the object area on the right: 

 
Column Description 
Status Displays status information, such as OK, defective, used 

See Status Icons for License Keys 
Family Displays the respective family, e.g., "SIMATIC STEP 7" 
Product Displays the respective product, e.g., "STEP 7" 
Version Displays the version identifier of the software product, e.g., "5.4" 
Number of license keys Displays the number of available license keys 
Order number Optional 
Standard license type Indicates the standard type of the license, e.g. Single, Floating, Master or Upgrade 
License type The following licenses are available: 

• Without restrictions (Unlimited) 
• Count relevant (tag/s) 
• Countable Objects 
• Rental (Limited Hours, Limited Days, Expiration Date) 
• Trial (Limited Days) 
• Demo (Limited Hours, Limited Days, Expiration Date) 
• Power Pack  

Validity period The following options are available for validity: 
• "Without restrictions": unlimited 
• "Count relevant": number of tags 
• Countable Objects: counts application-specific objects. 

Booked counter reading is retained after the computer is restarted. 
• "Rental": remaining time + unit / date 
• "Trial": remaining time (total runtime)  
• "Demo": Remaining time + unit / date 
• "Master": as stipulated in the agreement 
• "Upgrade": as stipulated in the agreement 
• "Power Pack": as stipulated in the agreement 

License number Serial number of the software license 
(10-digit = authorization; 20-digit = license key) 



Working with the Automation License Manager  
3.1 User Interface 

 Automation License Manager V5.3 
22 Manual, 12/2013, A5E32921785-AA 

Column Description 
Optional columns 
Manufacturer For example,  Siemens AG 
Computer Name of the computer where the license key is located 
License key Name of the license keys 
Storage location Respective storage location: My Computer (local) or network computer 
Last used Currently, no function 
User User of the license key 
Computer used Computer that is using the license key 
HW serial number Displays the hardware serial number 
Quantity of software Optional 
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3.1.3 Settings in the Automation License Manager 

Make the following settings in the "Settings" dialog.  

"Settings" Dialog 
1. Select the menu command File > Settings. 

The "Settings" dialog opens. 

2. Enter the desired settings. 

3. Close the dialog with "OK". 

 
Set what? Make settings in: Action: 
Access protection 
 

"General" tab To support access protection for license keys, certain requirements must 
be met. Refer to "Access Protection via SIMATIC Logon Role 
Management" for the requirements.  

Blocking of external 
accesses  

"General" tab If you want to prevent: 
• Network computers from using a license key, select the "Forbid 

remote use of license keys" check box. 
• License keys from being removed from the local computer, select 

the "Forbid license keys transfer from local computer" check box. 
• License keys from being added onto the local computer, select the 

"Forbid license keys transfer to local computer" check box. 
All fields can be combined. 
The check boxes are cleared when SIMATIC Logon is installed and the 
"Activate SIMATIC Logon access protection" check box has been 
selected. 
See also: "General" tab - Settings  

Language "General" tab Select one of the available languages in the drop-down list box. 
See also: "General" tab - Settings  

Search order "Favorites" tab The list of "Known computers" on the left side of the "Favorites" tab 
indicates the computers that have been connected to the local 
Automation License Manager at some point in the past. 
Note: The verification of license keys is performed only on computers 
included in the "Search list" tab on the right-hand side. The search order 
is from top to bottom. Select the computer you want to be searched first 
for floating license keys and move it to the top of the list.  
See also "Favorites" tab - Settings  

Connection to other 
computers  

"Connection" tab Define the required connection settings in this tab.  
Remember that you will need to adapt your firewall settings to allow a 
connection to other computers. 
See also "Connection" tab - Settings  

User-defined settings "Reset" tab In this tab, you can reset or delete the user-defined settings you have 
made. 
See also: "Reset" tab - Settings  



Working with the Automation License Manager  
3.1 User Interface 

 Automation License Manager V5.3 
24 Manual, 12/2013, A5E32921785-AA 

Set what? Make settings in: Action: 
Upgrade check and 
checkout of license keys 

"License keys" tab In this tab you activate:: 
• The upgrade check  
• The transfer mode for the checkout of license keys  

Note:  
If you select the option "Upgrade", your computer automatically checks 
for existing but not yet used upgrade license keys when the program 
starts. 
If you select the option "Check out", a license key transfer to a 
connected computer is logged as checked out. The license keys which 
are checked out can be used on the connected computer and then later 
transferred back to the computer which is acting as the server. 
See also: "License Keys" Tab -  Settings  
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3.2 Status Icons in the Automation License Manager 

Meaning for License Keys 
 

 Note 
Some icons are labeled inactive in the description column of the following table. License keys with 
these icons are not operational. This may be caused by an incomplete offline transfer in which the 
activation code was not received. 

 
Icon  Description 

  Status of license keys unknown  

  License key "OK" 

  License key in use when last queried 

  License key is corrupt  
(recover with support from hotline) 

  Inactive - status of license keys unknown 

  Inactive - license key available but not activated  

  Inactive - license key is corrupt  
(recover with support from hotline) 

  Regular utilization time of a time-limited license key has expired 

  Additional grace period for utilization of a time-limited license key 

  Additional grace period for a time-limited license key that was being used at the time of the 
request. 

  Regular utilization time and additional grace period of a time-limited license key has 
completely expired 

  The supply of license keys has been exhausted; no other license keys are available. 

  The license key cannot be transferred. 

 

Meaning for Installed Software 
 
Icon  Description 

  Basic icon for software on the computer  

  Software has a valid license key 

  Software does not require license key 

  Software is installed on the computer > License key is already utilized 

  Software is installed on the computer > A valid license key is not present 

  Software is installed on the computer > A license key is present but is defective 
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Meaning for the Status in the "Log" View 
 
Icon  Description 

  Designates information 

  Designates a warning 

  Designates an error 

 

Meaning of the folder 
 
Icon  Description 

  Designates a folder in which computer connections can be stored. 

  Designates a license key folder, in which license keys can be stored. 
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3.3 Views in the Automation License Manager 

3.3.1 Default Views 

The following default views are available in the Automation License Manager after installation:  

 
Default View Description 
Search results Displays the search options in the "Find" view on the left and, following a 

successful search, the associated search results on the right. 
License keys Displays all license keys that are available on the selected drive in the 

"Management" view. 
Installed software  Shows the installed software products on the selected computer that require a 

license key. 
If a second number is displayed in parentheses in the "Version" column when you 
display the installed software, then the version of the license key shown in 
parentheses is used for the installed product version.  

Missing license keys Shows the installed software products that are missing a license key. 
Licensed software Displays the installed software products for which a license key is available on the 

selected computer. 

 
 Note 

Default views can only be copied; they cannot be deleted or changed. 

 

3.3.2 Overview of the "Management", "Find", and "Log" Views 

You can access the different views in the Automation License Manager by selecting the View > 
Management/Find/Log menu command. 

 
View Description 
Management • Displays a structure with computers and folders 

• Enables execution of all tasks for license management 
Find • Displays a search dialog and the respective search results 
Log • Displays local and network computers 

• Displays information about the transfer of license keys. 
• Displays log entries 
• Displays transfer actions for the check out and check in of license keys 
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Working with Multiple Views 
Presently, you can only work with one view at a time in the work area of the Automation License 
Manager (similar to Windows Explorer). However, the Automation License Manager can be started 
multiple times.  

By opening several sessions of the Automation License Manager, you can move license keys 
within the application and between two windows. 

 
 Note 

The Automation License Manager has a session log that saves user-specific settings automatically. 
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3.3.3 "Management" View 

In the "Management" view, you can select and activate available views or define your own views. 
The Automation License Manager comes equipped with a few predefined default views for the 
management view.  

Procedure: 
1. Select the view using the View > Management menu command. 

2. The currently selected view in the drop-down list box on the menu bar is used to display 
information in the object area. 

3. Select the View > Define menu command. 
The "Define View" dialog opens. Here, you can access information using existing views or 
define a new view. 

Define View 
 
Button Description 
OK The view selected in the "Available views" list is used to display information in the object area. 
Apply Views can be edited in the expanded "Edit view" area. 

Changes become active when you click "Apply". 
Cancel Close the "Define View" dialog without applying the changes. 
New Define a new view 
Copy Copy an existing view 
Delete Delete an existing view 

 

"New", "Copy" and "Delete" Buttons 
The "New", "Copy" and "Delete" buttons operate on the views displayed in the "Available views" 
list.  

"Edit View" Area 
The name of the view is shown in the "Name" field. This name appears in the view as the heading 
of the object area and in the drop-down list box on the toolbar.  

You can use the radio buttons to preselect the filtered contents of a view that are to be displayed: 

• License keys – only license key information is available for selection. 

• Software - Only software information is available for selection. 

You can define the content and layout of the views as follows in subsequent tabs: 
• Columns, 

• Filters, 

• Groups and 

• Sort. 
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3.3.4 "Find" View 

You can search for information on license keys and installed software in the "Find" view in the 
Automation License Manager. 

Procedure: 
1. Select the view using the View > Find menu command. 

2. Make the following settings in the "Find" area: 

- Enter a "search term" and/or "product" as necessary. 

- Select criteria in the "Storage location", "Standard license type", "License type", "Status", 
and "Used by" lists. 

3. Click on the "Find now" button to begin the search. 

Result: The search results are displayed in the object area.  

Example: Find a License Key in the Network 
1. Select the view using the View > Find menu command. 

2. Make the following settings in the "Find" area: 

- Enter the term "STEP 7"  in the "Search term" edit box, for example. 

- Select "All" in the "Storage location" list. 

- Click on the "Find now" button. 

Result:  

All license key are displayed that: 

• Contain the term "STEP  7", and  

• Are present on your own computer or a network computer 
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3.3.5 "Log" and "Checkout" Views 

The "Log" view provides information on all operations that involve license keys (such as use of 
license key by software, transfer of license keys,checkout of license keys). 

Opening a Log 
1. Open the view using the View > Log menu command. 

2. Select the desired view from the drop-down list box:Log view or Checkout view. 

3. In the object area, select the location (My Computer, network computer) where you want to 
open a log.  

4. Select the desired number of entries or select the time period for which logs are to be 
displayed. 

5. Select the "System entries" check box if you want system entries to be displayed, too. System 
entries are additional entries which are relevant for customer support and the Automation 
License Manager system. 

6. Select the "Filter" check box if you want to use a filter. Select the desired filter from the drop-
down list box. 

7. Click "Update". 

Result: The log entries corresponding to the selected criteria are displayed for the selected view.  

 
 Note 

The checkout log displays all actions regarding the checkout of license keys that have not yet been 
completed. It shows all license keys checked out from the server that have not yet been checked in 
again. 

If a license key has been checked out and then checked in again, the action has been completed 
and therefore is not shown in the checkout log. 

 

Print Log 
1. Open a log. 

2. To print the log, select the File > Print menu command. 

3. Correct in the settings if necessary and confirm the dialog with "OK". 

Result: The displayed log entries are printed out. 
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Archive Log 
1. Open a log. 

2. To archive a log, select the File > Export menu command. 

3. Enter the drive and storage path. 

Result: The displayed log entries are stored in the specified path in CSV format. 

Delete Log  
1. To delete all entries in a log, select the Edit > Delete Log menu command. 

Result: All log entries of the selected computer are deleted. 
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3.4 Handling License Keys 

3.4.1 Installing License Keys 

Installing License Keys during the Installation of the Software Product 
Some software products allow you to install the required license key during the installation (setup) 
of the program itself. The license key is then installed on the computer where the software is 
installed. 
 

 Note 
Note that upgrade license keys cannot be installed during the setup program. 

 

3.4.2 Displaying the Installed License Keys 

You can list all installed license keys using the View > Management menu command.  

Procedure: 
1. Select the view using the View > Management menu command. 

2. In the navigation area, select the computer (My Computer or network computer) and the drive 
from which you want to see the installed license keys 

3. Select the View > Define menu command. 
The "Define View" dialog opens. 

4. Select the "License keys" view and click "OK". 

Result: The installed license keys on the computer are displayed. 
 

 Note 
When available license keys are not recognized by corresponding components, check the following 
columns:· 

• Version 

• Validity period 

• Status (Select license keys, select View > Update, then License Key > Check) 
 

Printing or Exporting a List 
A list can be: 

• Printed by selecting the File > Print menu command, or  

• Exported to a CSV file with the menu command File > Export 
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3.4.3 Displaying the Installed Software 

You can list all installed software products that require a license key for operation by selecting the 
View > Management menu command. 

Procedure: 
1. Select the view using the View > Management menu command. 

2. Select the View > Define menu command. 
The "Define View" dialog opens. 

3. Select the "Installed Software" view and click "OK". 

Result: The Siemens AG software products installed on the computer that support the new license 
concept (using license keys) are displayed. 

 
   Note 

If a second value is indicated in parentheses in the "Version" column when displaying the installed 
software, then the version of the license key shown in parentheses is used for the installed version.  

 

Printing or Exporting a List 
A list can be: 

• Printed by selecting the File > Print menu command, or  

• Exported to a CSV file with the menu command File > Export 
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3.4.4 Transferring License Keys 

The following options are available for transferring license keys between various storage 
locations (for example, computers, USB memory sticks and license key folders): 

• Using a drag-and-drop operation 

• Using a cut-and-paste operation 

• Using the License Key > Transfer menu command. 

• Using the License Key > Offline Transfer menu command, you can transfer the start code, 
request code, and activation code manually (see "License Key Offline Transfer" Dialog). 

Transferring License Keys Using Drag-and-Drop 
1. Select the view using the View > Management menu command. 

2. Open the storage location on the local or network computer where you wish to remove the 
license keys. 

3. Select the license keys and drag them to the storage location where you wish to place the 
license keys. 

Result: The license keys are now transferred. 

Transferring License Keys by Cutting and Pasting 
1. Select the view using the View > Management menu command. 

2. Open the storage location on the local or network computer where you wish to remove the 
license keys.  

3. Select the license keys you want to transfer. 

4. Select the menu command Edit > Cut. 

5. Open the storage location on your own computer or network computer where you want to place 
the license keys.  

6. Select the Edit > Paste menu command. 

Result: The license keys are now transferred. 
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Transferring License Keys Using the License Key > Transfer Menu Command: 
1. First, select the license keys you want to transfer to another storage location. 

2. Select the License Key > Transfer menu command to open the "Transfer License Keys" 
dialog. 

3. Select the desired destination drive in the drop-down list box or click "Network..." if the 
destination drive is on another network computer. 
The "Connect Computer" dialog opens. 

4. Enter the computer name or select the desired computer in the drop-down list box, or  

- Click "Browse" to open the "Search for a Computer" dialog.  

- Click "Entire Network", and then click "Microsoft Windows Network".  

- If the computer is located in a domain, select this domain. 

- Then, select the desired computer and click "OK" to confirm your selection. Note that the 
Automation License Manager must also be installed on the selected computer. 

5. Click "OK" to confirm your selection and close the dialogs. 
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3.4.5 Creating folders 

To store existing computer connections and license keys in a structured manner, you can create 
folders. Computer connections are stored in general folders. Special license key folders are 
required to store license keys and these folders are designated by an additional icon. 

Dependencies for creating new folders: 
The new folder may be a general folder or a license key folder, depending on where it 
is created. 

 
Icon  Description 

  Indicates a folder in which computer connections can be stored. 
To create such a folder, before creating the folder in the navigation area, alternatively select: 
• My desktop 

  Indicates a license key folder, in which license keys can be stored. 
To create such a folder, before creating the folder in the navigation area select: 
• Local data carrier 
• Already existing license key folder 

 

Procedure: 
1. Select the "Manage" view. 

2. In the drop-down list within the menu bar, select the "License Keys" view. 

3. Selected the required object in the navigation area, as described in the above table. 

4. To create a general folder, select "My desktop". 

5. To create a license key folder, select a "Local data carrier" folder or an already existing license 
key folder. 

6. Using the shortcut menu or the menu, select the command "Edit > New Folder". 

7. Enter the desired name for the new folder in the following "Add a new folder" dialog. 

8. Click "OK" to confirm.  

Result: The new folder with the name you assigned is displayed in the navigation area. 
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3.4.6 Managing License Keys in Folders 

Storing and managing license keys in folders 
As of Version V5.2 of the Automation License Manager, special license key folders can be created 
for managing license keys. 

The folders in the Automation License Manager are designated by the following icons: 

 
Icon  Description 

  Designates a folder in which computer connections can be stored. 

  Designates a license key folder in which license keys can be stored. 

 

Actions with license key folders 
License key folders can be moved as usual via drag-and-drop operation, cut, pasted and renamed. 

Empty license key folder can also be deleted; this operation is no longer possible when 
the folder contains any license key. 

Storing license keys in license key folders 
The creation of license key folder allows you to store license keys in a hierarchically structured 
product and version specific manner. This provides you with a better overview of the existing 
license keys, as the following example shows: 
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You can also save License Keys without a folder structure, as shown in the figure above. If 
however, there is a license key folder available, it is showed first and then the individual license 
keys after it. 

Displaying the validity of licenses 
An additional advantage of the license key folder is that, in the case of license keys of the type 
"Count relevant" or "Countable Objects", the total number of available "tags" (variables or 
application specific objects) is displayed in brackets after the folder name. As the following example 
shows, the opened folder contains several license keys with differing validity, which are displayed 
as sum in brackets after the folder name. 

The first number indicates how many "tags" are still available, the second number after the colon 
indicates the total number of available "tags". 

  

 
 Note 

Please note that it is not possible to delete license key folders when these contain license keys. 
License key folders can only be deleted when they are empty. 
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3.4.7 Determining and Synchronizing License Requirements 

You can use the dialog box below to license software products on your own computer that do not 
yet have license keys, provided that license keys are still available. 

Procedure: 
1. Select one of the predefined views "Installed Software", "Missing License Keys", or "Licensed 

Software" using the View > Define menu command. 

2. Select the License Key > Synchronize License Requirements menu command. 

- Select the drive where the license keys are to be installed in the drop-down list box. 

- Select the option for the source of the license keys to be transferred. You can use the 
"Network" button to navigate to any computer in the network. 

- The "Which software products do you want to license?" field displays the software products 
on your computer that lack a valid license.  
Already licensed software is listed but cannot be selected. Click the "+" to see which 
licenses are available for the respective software. 
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3. Here, you select which of the displayed software products is to be licensed and click "OK". The 
"OK" button does not become active until you have selected a software package to be 
licensed. 

4. If the selected software package could not be licensed because, for example, the specified 
source computer does not contain a valid license key, you will receive a message and the 
dialog will appear again. 
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3.4.8 Offline Transfer of License Keys 

The License Key > Offline Transfer menu command opens the "License Key Offline Transfer" 
dialog.  

 
 Note 

To perform an offline transfer of license keys, both the Automation License Manager as well as the 
software using the license key must be installed on both computers (source and target). 

 

Select the offline transfer step you want to perform and click "Next".  

You have the following options: 
• Generate start code 

• Generate request code 

• Generate activation code 

• Activate license keys 

The wizard for the offline transfer guides you step by step through the transfer. 
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3.4.9 License Profile Files for the Offline Transfer of License Keys 

A license profile file is used to exchange information for the (offline) transfer of license keys. The 
(offline) transfer is performed in 5 steps. Different data are included in the license profile file for 
each step of the process. 

Transfer of Data 
A license profile file can be provided in electronic form (for example, per diskette or e-mail). 

Validity of a License Profile File 
 

 Note 
License profile files are only valid for one-time transfer of a group of license keys. Generation can 
only be repeated with new files. 

The following data are saved in a license profile file for offline license transfer: 
• Product name - name of the component 

• License number - specific number for the license key transfer 

• Start code  

• Request code  

• Activation code  
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3.5 Web License Key Download 

3.5.1 Web License Key Download 

The software download enables you to access ordered license keys. 

Requirement 
For access, you need: 

• A personalized logon that you can use to retrieve all license keys assigned to "your company". 

• An anonymous logon that you can use to retrieve an individual license key, and the CoL 
(Certificate of License). This document contains all data required for the anonymous download. 

Procedure: 
If your computer is located in a stand-alone network or a network with a low security level, we 
recommend the following procedure: 

1. Also install the Automation License Manager on a computer with Internet access that is located 
outside of the automation system. 

2. Perform the Web License Key Download (see following section). 

3. Transfer the license keys to a license key diskette and then from the license key diskette to the 
computers of the automation system.  

 
 Notice 

Always verify that the transfer media are virus-free. 
 

Web License Key Download 
1. Select the Management  view. 

2. Click "Web License Key Download" in the navigation area. 
If the computer has Internet access, the Automation Download Manage opens the window in 
the object area. 

3. Follow the instructions in the download window for downloading a license key. 
 

 Notice 
• If you receive an error message that the software download server is unavailable, check your 

firewall settings and contact your system administrator, if necessary. 

• If you receive an error message that the software download server is not ready for operation at 
the moment, make another attempt after a while.  
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3.5.2 Web License Key Download - "Back" Button   

Use the "Back" button to return to the previously displayed page. 

• Click the "Forward" button if you want to display a page that you visited before clicking the 
"Back" button.  

3.5.3 Web License Key Download - "Cancel" Button   

Use the "Cancel" button to stop downloading the current page. 

3.5.4 Web License Key Download - "Forward" Button   

Use the "Forward" button to return to the previously displayed page. 

 
 Note 

The "Forward" button is available for selection only after you have clicked the "Back" button. 

  

3.5.5 Web License Key Download - "Start Page" Button   

The "Start Page" button sends you to the start page of the "Web License Key Download". 
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3.6 Using License Keys in the Network 

3.6.1 Searching for Existing License Keys in the Network 

Using Software with an Available License Key in the Network 
An available floating license key (on a network computer) enables operation of a protected 
software product when a license key is not locally available.  
 

 Note 
To search for license keys on a network computer, the network computer must be entered in the 
Automation License Manager on the local computer. 

 

Recommendation for Faster Access to Floating License Keys 
Install all floating license keys in a system on as few computers as possible.  
 

 Note 
In the menu File > Settings > "Favorites" tab you will see the computers that have been 
connected to the local Automation License Manager at some point in the past under "Known 
computers". 

 

You can influence access to floating license keys as follows: 
1. Make sure that the computers where the floating license keys are located are entered in the 

"Search list". To do so, select the Edit > Connect Computer menu command. 

2. Move the computers where the floating license keys are located to the top positions in the 
"Search list" in the "Settings" dialog, and delete unnecessary entries. 

 
Button Icon Description 
Move up   Click the "Move up" icon to change the order that the computer selected in 

the list will be searched for a floating license key. Shifts the computer to 
the next higher position (in the view, the top position corresponds to the 
first computer, etc.). 

Move down   Click the "Move down" icon to change the order that the computer 
selected in the list will be searched for a floating license key. Shifts the 
computer to the next lower position (in the view, the top position 
corresponds to the first computer, etc.). 

Delete   Click the "Delete" icon to delete the computer selected in the list from the 
search for a floating license key. 

  



 Working with the Automation License Manager 
  3.6 Using License Keys in the Network 

Automation License Manager V5.3 
Manual, 12/2013, A5E32921785-AA 47 

3.6.2 Connecting Computers over a Network 

The Edit > Connect Computer menu command opens the "Connect Computer" dialog. Here, you 
can establish a connection to a network computer and enable the computer for management of 
license keys. 

 
 Note 

Only computers that have the Automation License Manager installed can be connected. 

 

Procedure: 
1. Select the "Management" view.  

2. If the computer connection is to be stored in a folder, create a new folder beforehand. 

3. Select the Edit > Connect Computer menu command. 

4. Under "Computer Name", enter the name of a computer on the network or select one from the 
drop-down list box. The following can be used for the computer name: "ComputerName", or 
"ComputerName.Domain" and "IP address". 

5. To search for a computer in the network, click "Browse". 

6. Double-click "Entire network". 

7. Double-click "Microsoft Windows Network".  

8. If the computer is located in a domain, select this domain. 

9. Select the computer and click "OK" to confirm. 

10. Under "Display name", you can enter any "display name" for the computer (default = computer 
name:port number). 

11. Select the "Always display in navigation window" check box if the entered computer is to be 
available after a restart of the Automation License Manager. 

12. Select the "Add to search list" check box if the entered computer is to be incorporated in the list 
of computers to be searched for license keys. The network computer is displayed in the 
"Favorites" tab of the "Settings" dialog (select File > Settings menu command).  

13. Click "OK" to confirm. 

Result: The computer has been added in the navigation area or the "Error connecting computer" 
dialog opens. If the latter occurs, verify that the entered computer is available on the network. 
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3.6.3 Failure of Computer Connections 

Computers operating over a network connection can use only floating license keys. This section 
describes the response of floating license keys when the connection between network computers 
fails. 

License Key Server  
A license key server is a computer on which a floating license key is stored. 

License Key Client  
A license key client is a computer which uses a floating license key from a server. 

Connection Failure Scenarios 
When a floating license key on a license key server is used by a software product on a license key 
client and the connection between the two computer fails, it may be due to the following: 

• The software product has crashed. 

• The network connection has been interrupted. 

• The license key client has crashed. 

• The license key server has crashed. 

Software Product Has Crashed 
The Automation License Manager on the license key client monitors usage of the license keys by 
the software product. If the client crashes, the Automation License Manager immediately releases 
the relevant license keys on the license key server.  
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Network Connection Has Been Interrupted 
Following a failure of the network connection to the license key server, the software product on the 
license key client can continue to be used for up to 3 hours. 

The floating license keys on the license key server remains "used" for a maximum of 3 hours.  

The license key is no longer found when the software is restarted and therefore cannot be 
reassigned. 

Scenarios: 

• If the interruption lasts less than 3 hours, then: 

- The Automation License Manager on the license key server detects both the license key 
client (the computer that used the license keys) and the "used" license keys.  

- It then allocates the still valid "used, previous" license keys to the detected license key 
client. 

• If the interruption lasts more than 3 hours, then: 

- The license keys on the license key server are released.  

- License key clients are operated the same for an initial contact.  

- After 3 hours, the previously connected license key client automatically attempts to find a 
valid license key. When no license key is available, the application-specific reaction to 
unavailable license keys is started (for example, notification after a defined period). 

License Key Client Has Crashed 
• If the interruption last less than 3 hours, the license key client detects that the connection to the 

server is established and automatically requests the "used" license key once again. 

• The license key on the license key server is released if the interruption lasts longer than 3 
hours.  

License Key Server Has Crashed 
• If the interruption last less than 3 hours, the license key client detects that the connection to the 

server is established and automatically requests the "used" license keys once again. 

• If the interruption last more than 3 hours, the license key client automatically attempts to find a 
valid license key. When no license key is available, the application-specific reaction to 
unavailable license keys is started (for example, notification after a defined period). 
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3.7 Repair of License Keys 

3.7.1 Checking License Keys 

Procedure for Checking License Keys: 
1. Select the view using the View > Management menu command. 

2. In the object area, select the storage locations (My Computer, network computer, license key 
folder) where the license key that is to be checked is stored. 

3. Select the license key to be checked. 

4. Select the License Key > Check menu command.  

Result: The selected license key is checked, and the result is displayed using a status icon for 
license keys. 

3.7.2 Recovering License Keys 

The License Key > Recover menu command calls the dialog for restoring license keys. 

Procedure: 
1. Select the license key to be restored and select the License Key > Recover menu command. 

2. Connect to "Support for License Management" and provide the data indicated in the dialog box: 

- Product name 

- License key number 

- License number 

- Request code 

3. Enter the supplied activation code and click "OK". 

Result: The defective license key has been recovered and is now available for use. 

 
 Note 

Authorizations can only be repaired on diskettes and license keys can only be recovered on hard 
disks. 
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3.7.3 Recovering License Keys Using the Wizard 

The License Key > Recover Wizard menu command opens the "Wizard for Restoring License 
Key(s)" dialog.  

You can use the "Recover Wizard" to repair one or more license keys that are no longer available 
due to loss or a defect on the hard drive. Help from "Support for License Management" is required 
to restore the license key(s).  

The wizard guides you step by step through the entire process. The following dialogs are called: 

• Recover Wizard: Select License Key 

• Recover Wizard: Enter Repair Codes 

• Recover Wizard: Result 

3.7.4 Help from "Support for License Management" 

Below please find the language-specific Internet addresses to reach the "Support for License 
Management": 

 
German http://support.automation.siemens.com/WW/view/de/772175 
English http://support.automation.siemens.com/WW/view/en/772175 
French http://support.automation.siemens.com/WW/view/fr/772175 
Spanish http://support.automation.siemens.com/WW/view/es/772175 
Italian http://support.automation.siemens.com/WW/view/it/772175 
Chinese http://support.automation.siemens.com/CN/view/zh/772175 
Japanese http://support.automation.siemens.com/WW/view/en/772175 

 

The employees at "Technical Support" and "Support for License Management" speak German and 
English. 

http://support.automation.siemens.com/WW/view/de/772175
http://support.automation.siemens.com/WW/view/en/772175
http://support.automation.siemens.com/WW/view/fr/772175
http://support.automation.siemens.com/WW/view/es/772175
http://support.automation.siemens.com/WW/view/it/772175
http://support.automation.siemens.com/CN/view/zh/772175
http://support.automation.siemens.com/WW/view/en/772175
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3.8 Access Protection for the Automation License Manager 

3.8.1 Access Protection via SIMATIC Logon Role Management 

Role Management with SIMATIC Logon  
The role management of the SIMATIC Logon optional package can be used to regulate access by 
users and user groups to functions of the Automation License Manager. This access protection 
applies to individual functions and not to the application as a whole. 

• The access protection forces users to log onto the system in order to use the Automation 
License Manager and its functions. 

• The role management is based on the users and user groups of the operating system. 

• The assignment of specific tasks to roles (see table) enables easy configuration of rights for 
users and user groups.  

• If SIMATIC Logon is installed and access protection is activated, the applications check directly 
to determine if the logged-on person has the right to use certain functions. To prevent duplicate 
administration and checking of these persons, the right to assign license keys is granted to all 
persons. 

Requirement 
To apply the role management and activate the access protection, the following requirements must 
be met: 

• The users and user groups must be set up in Windows. 

• The SIMATIC Logon optional package must be installed. 

• The "Logon_Administrator" user group must have been set up (see online help for SIMATIC 
Logon). 

The user currently logged onto the computer must have the right "Activate/deactivate access 
protection" (File > Settings). 
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Principal Terms 
 
Term Description 
Rights • Rights are defined by the SIMATIC Logon role management. 

• Rights cannot be added or deleted. 
Users / user groups Users and user groups are defined in user accounts on the computer.  
Access protection Access protection grants certain users and user groups the right to perform certain 

operations. Roles are used to facilitate management. 
Roles A role includes the authorization for user groups/users to perform certain actions 

within the Automation License Manager (for example, transfer data). 
• Users and user groups can be assigned one or more roles. Users can have all 

rights defined for these roles. 
• Basic default roles are supplied with the SIMATIC Logon role management. 
• Custom roles can be added or deleted as desired. 
• Rights can be added or deleted to roles.  
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3.8.2 Calling and Activating SIMATIC Logon Role Management 

Procedure: 
1. Select the File > Role Management menu command to open the role management. 

The "SIMATIC Logon AdminTool" dialog opens. 

2. Assign at least one user the role of administrator. 

3. Save your changes and close the "SIMATIC Logon Role Management" dialog. 

 
 Note 

You can find instructions for working in the "SIMATIC Logon Role Management" dialog in the 
online help for SIMATIC Logon in " "SIMATIC Logon Role Management" Dialog. 

 

4. Select the File > Change Logon menu command to open the "SIMATIC Logon Service" 
dialog, and log on with a user name having at least administrator rights. 

5. Select the File > Settings menu command. 
The "Settings" dialog opens. 

6. Select the "Activate SIMATIC Logon access protection" check box. 

 
 Note 

• If the "Activate SIMATIC Logon access protection" check box is cleared, all users can make 
changes in the role management. 

• If the "Activate SIMATIC Logon access protection" check box is selected, only users with the 
"Activate/deactivate access protection" right can make changes in the role management. 

 

7. Click "OK" to apply the settings. 
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3.8.3 Function Rights and Roles for the Automation License Manager 

The following function rights and roles are specified: 
 

Function Roles 

 Licensor Administrator Main user User 

Transfer license keys X X X  

Check license keys X X X X 

Recover license keys X    

Upgrade license keys X X X  

Display license keys X X X X 

Read log X X X  

Delete log X X   

Activate/deactivate access protection X X   

Change projects X X   

 
 Note 

The "Change projects" right means that you can assign roles and function rights for access to the 
Automation License Manager. 

  



Working with the Automation License Manager  
3.8 Access Protection for the Automation License Manager 

 Automation License Manager V5.3 
56 Manual, 12/2013, A5E32921785-AA 



 

Automation License Manager V5.3 
Manual, 12/2013, A5E32921785-AA 57 

Glossary 

Assignable License Key 
License key that can only be used on hardware with a specified serial number. The licenses 
associated with the license key are assigned to the hardware. 

Assigned License Key 
A license key is assigned to a system for it operation. 

Certificate of License (CoL) 
Proof of license; legally identifies the license owner. Contains the license number for unique 
identification of the license.  

Count relevant License 
Use of the software with this license is limited to the number of tags stipulated in the agreement. 

Countable Objects License 
The use of the software with this license is limited to the number application-specific objects named 
in the contract. 

"Define" View 
Defines the content and layout of the "Management" view. 

Demo License 
Use of the software with this license is limited to the use conditions stipulated in the agreement. 

Tooltips on the time remaining for the demo license are displayed in the information area of the 
taskbar. 

Embedded (Runtime) System 
A non-Windows system that is running the runtime software; typically features special hardware. 

Engineering Software 
Software that is used to create, test and commission automation solutions. 
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Floating License 
Right to use software simultaneously on multiple computers for an unlimited period. The software 
can be installed at multiple locations. 

Installed Software 
Software that is installed on a computer. 

License 
Right of the license owner to use software in conformity with the License End User Agreement. 

License Key 
Stored information that technically represents the ownership of one or more licenses. 

License Number 
The license number is the unique identifier of a license. 

Master License 
Use of the software with this license is unlimited. 

Rental License 
This license permits the use of the software limited to a period of operating hours or days or until a 
period expires as stipulated by the agreement. 

Service Pack 
Officially available remedy for errors in software; does not require a new license. 

Single License 
The use of the software with this type of license is permitted on any one computer for an unlimited 
period. The type of usage is defined by the certificate of license. 

Software Option 
From the point of view of license management, software that is technically dependent on other 
software or firmware. 
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Storage Location for License Keys 
Drive (hard disk, floppy drive, USB memory stick) on a computer (My Computer or network 
computer) where a license key is or can be stored. 

Trial License 
This license limits the use of the software to a specified number of days from the time it is first 
used. The software may only be used for purposes of testing and validation (liability excluded). 

Unlimited License 
This license enables unlimited use of the software. 

Upgrade License 
An upgrade is a transition from version x to version >x of the software. An upgrade may demand 
specific requirements on the system status. An upgrade may be required if you wish to increase the 
number of computers running an application. 
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