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Hälytysjärjestelmän tehtävät

Hälytys-
järjestelmä

Näyttö

Arkistointi

RaportointiDB File

Operointipaneelin hälytysjärjestelmällä on seuraavat tehtävät:

Näyttö Ilmoittaa ja näyttää laitoksen tai prosessin tapahtumat tai tilat. Hälytysilmoitus
näytetään välittömästi tapahtuman tullessa.

Raportointi llmoitukset tulostetaan kirjoittimelle.
Arkistointi Ilmoitukset talletetaan myöhempää käsittelyä ja analysointia varten tiedostoon tai

tietokantaan.

Talletus puskuriin Kaikki ilmoitukset talletetaan väliaikaiseen kiertopuskurimuistiin, „Message buffer“.  
Puskurin koko riippuu operointipaneelin tyypistä. Puskuri nollautuu jännitekatkossa.

Mallit - Wizard WinCC Flexible wizard luo hälytysten käsittelyyn vakionäytöt Template-pohjakuvaan. 
Seuraavassa käydään läpi eri hälytysmäärittelyt ja oman hälytysikkunan konfigurointi.

Hälytysten käsittelyyn on myös useita systeemifunktioita, joita voi liittää erilaisiin
tapahtumiin. Näistä löytyy lisätietoja esim. Online Help tiedostosta.

PLC ohjelm a:
U E1.2
= M3.0

Halutut hälytystekstit

M3.1 Rajakytkin ylipaine

Ohjauspaneelin hälytystekstilista:
1 Rajakytkin ylipaine
2 ….
Esim.  OP/TP Discrete Alarms
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Hälytykset - menettelytavat

Bittihälytysmenettely
Operointipaneeli  liipaisee hälytyksen, jos logiikassa asetetaan
tietty bitti

Analogiahälytysmenettely
Operointipaneeli  liipaisee hälytyksen, jos muuttuja ylittää tai alittaa 

annetun raja-arvon

Hälytysnumeromenettely
Logiikan hälytysohjelmalohko liipaisee hälytyksen. Asiaankuuluva 
hälytysnumero lähetetään operointipaneelille ja siihen kuuluva hälytys 
näytetään.

Hälytysmenettely kertoo, minkätyyppinen tieto liipaisee hälytyksen, ja kuvaa hälytyksen 
ominaisuudet. 
WinCC flexible tukee seuraavia hälytysmenettelyitä:

Bit message Bittihälytysmenettely: Operointipaneeli  liipaisee hälytyksen, 
procedure jos logiikassa asetetaan tietty bitti. Bittihälytykset osoitetaan hälytyssanoittain.

Analog message Analogiahälytysmenettely: Operointipaneeli  liipaisee hälytyksen, 
Procedure jos muuttuja ylittää tai alittaa annetun raja-arvon.

Message number Hälytysnumeromenettely: Logiikka lähettää operointipaneelille
Procedure hälytysnumeron (ja siihen mahdollisesti liitetyn hälytystekstin). Nämä hälytykset

projektoidaan logiikassa tavallisesti ALARM_S lohkoilla. 

Message status Hälytystilat:
Bitti- ja analogiahälytyksissä erotetaan seuraavat hälytystilat:
Kun hälytyksen liipaisuehto täyttyy, hälytys saa tilan „saapunut“. Kun käyttäjä on 
kuitannut hälytyksen, se saa tilan „saapunut – kuitattu“.

Kun hälytyksen liipaisuehto ei enään ole voimassa, hälytyksen tilana on „saapunut –
lähtenyt“. Kun käyttäjä on kuitannut hälytyksen, sen tilana on „saapunut – lähtenyt –
kuitattu“.

Jokainen näistä tilatapahtumista voidaan näyttää operointipaneelilla ja arkistoida, ja se 
voidaan myös tulostaa kirjoittimelle.
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Hälytysluokat

Errors - virheet
bitti- ja analogiahälytykset, jotka ilmoittavat kriittisistä tai vaarallisista 
käyttö- tai prosessitiloista. (Vaatii kuittauksen)

Warnings - varoitukset
bitti- ja analogiahälytykset, jotka kertovat normaaleista käyttö- tai 
prosessitiloista tai prosessin kulusta. (Ei tarvitse kuitata)

System - järjestelmäilmoitukset
järjestelmäilmoitukset kertovat operointipaneelin ja logiikan
toimintatiloista (Eivät vaadi kuittausta)

Hälytysluokka määrittelee ennen kaikkea, miten hälytykset näytetään kuvassa. Lisäksi
hälytysluokilla voidaan ryhmitellä hälytykset eri esitystapoja varten. WinCC flexible 
sisältää ennalta määriteltyjä hälytysluokkia ja sillä voi toisaalta konfiguroida omia
hälytysluokkia.

Alarm classes Ennalta määritellyt hälytysluokat ovat:
Errors „Virheet“ ovat bitti- ja analogiahälytyksiä, jotka ilmoittavat kriittisistä tai vaarallisista

käyttö- tai prosessitiloista. Tämän hälytysluokan hälytykset vaativat aina kuittauksen.
Warnings „Varoitukset“ ovat bitti- ja analogiahälytyksiä, jotka kertovat normaaleista käyttö- tai

prosessitiloista tai prosessin kulusta. Tämän hälytysluokan hälytyksiä ei tarvitse kuitata. 
System „Järjestelmäilmoitukset“ kertovat operointipaneelin ja logiikan toimintatiloista. 

Järjestelmähälytykseen kuuluu hälytysnumero ja hälytysteksti. Hälytysteksti voi sisältää
sisäisiä muuttujia, jotka määrittelevät vian syyn tarkkaan.  
Tätä hälytysluokkaa ei voi käyttää käyttäjän määrittelemille omille hälytyksille.

Kuittaus Hälytyksen kuittauksen voi tehdä joko käyttäjä operointipaneelilla tai se voidaan kuitata
logiikkaohjelmassa. 

Acknowledge Käyttäjä kuittaa joko <ACK> painikkeella, funktio- tai softkey- painikkeella tai 
konfiguroidulla painikkeella. Kuittaus määritellään hälytyskohtaisesti.
Lisäksi hälytykset voidaan kuitata systeemifunktioilla funktiolistoissa tai scripteillä.
Logiikkaohjelmalla voidaan kuitata hälytykset, kun asetetaan muuttujan tietty bitti.

Alarm groups
Kuittausryhmä Lisäksi voidaan määritellä, kuuluuko hälytys johonkin kuittausryhmään, 

„Acknowledgement group”. 
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Hälytysten rakenne

ID kertoo
hälytysluokan

Hälytysnumero, yksilölliset
hälytysluokittain

Päivä ja kellonaika
koska hälytys generoitiin

Hälytyksen tila

A Activated tullut
D Deactivated poistunut
Ack Acknowledged kuitattu

Kuittausryhmä johon
hälytys kuuluu

Hälytysteksti 
prosessiarvoineen

Hälytykseen kuuluvat aina seuraavat osat:

Message text Hälytysteksti sisältää hälytyksen kuvauksen. Hälytysteksti kirjoitetaan merkeittäin
kirjasinlajeilla, joita käytettävä operointipaneeli tukee. 

Se voi sisältää hetkellisten muuttuja-arvojen näyttökenttiä tai tekstilistoja. 
Hälytyspuskuri tallettaa senhetkisen muuttuja-arvon, milloin hälytyksen tila on  
vaihtunut.

Message number Hälytysnumerolla viitataan tiettyyn hälytykseen. Se on yksiselitteinen kulloinkin
seuraavien hälytystyyppien sisällä:

Bittihälytykset
Analogiahälytykset
HMI systeemihälytykset
Yhden CPU:n lähettämät hälytykset

Trigger for the Liipaisu bittihälytyksillä on jonkin muuttujan tietty bitti
message ja liipaisu analogiahälytyksillä on valitun muuttujan raja-arvo. 

Message class Tiettyyn hälytysluokkaan kuuluminen määrää, pitääkö hälytys kuitata vai ei. Samoin se 
ohjaa, miten hälytys esitetään näytöllä.

Lisätiedot Hälytyksiin voi liittää lisätietoja informaatiotekstillä „info text”.
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Hälytysjärjestelmän perusasettelut

WinCC flexiblen hälytysjärjestelmä on periaatteessa toimintavalmis oletusasetuksin.  
Asetuksia muuttamalla voidaan tarvittaessa sovittaa hälytysjärjestelmän käyttäytymistä
laitoksen vaatimusten mukaisesti. 

Perusasettelut Perusasettelujen välilehti avataan Projekti-ikkunan kansiosta
Alarm Management > Settings > Alarm Settings

General General-taulukon “Report" optiolla voidaan valita käyttöön tai pois hälytysten tulostus
koko projektin osalta. Lisäksi voidaan aktivoida tulostus jokaiselle yksittäiselle
hälytykselle.
“Use … colors” valitaan hälytysluokkanäyttöön värien käyttö.

System alarms "System alarms" -alueella valitaan, mitä järjestelmähälytyksiä aiotaan näyttää
operointipaneelilla. 

S7 Integrointi
Alarm procedures STEP7:aan integroidussa moodissa voidaan hälytysnumeromenettelyn asettelut tehdä

“Alarm procedure" -alueella.
ALARM_S Hälytykset konfiguroidaan STEP7:ssa käyttäen  ohjelmayksiköitä ALARM_S ja

ALARM_D, jotka käyttävät hälytysnumeromenettelyä. STEP7:ssa hälytysnumerot
osoitetaan automaattisesti. Hälytystekstit osoitetaan yksiselitteisesti numeroiden
mukaan. Hälytysluokkia on nimetty 0 ..16.
Kun hälytykset konfiguroidaan STEP7:ssa, talletetut tekstit ja attribuutit talletetaan 
STEP7:n konfigurointitietoihin. WinCC flexible tuo automaattisesti tarvittavat tiedot ja 
siirtää ne myöhemmin operointipaneelille.

STEP7 HW STEP7:n HW-työkalulla toiminta kutsutaan CPU-kohdassa valikolla ”Options > Report
System Errors”.  Asiaa kuvattu tarkemmin STEP7 käsikirjoissa. 

SIMATIC SFM On/Off valitaan, pitääkö ALARM_S luokan systeemivirheilmoitukset näyttää.
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Hälytysluokkien konfigurointi

Esimerkki Konfiguroidaan hälytysluokka “Prosessi”. Tämän luokan hälytysten kaikki tilat pitää
esittää keltaisena ja lisäksi saapunut tila “Activated” vilkkuvana. Hälytykset pitää
kuitata. 

Avaa editori Avaa projekti-ikkunassa editori

Project window > Alarm Management > Settings > Alarm classes

Lisää hälytysluokka Merkitse tyhjä rivi ja käytä menuvalikon komentoa

Insert > New Object > Alarm class

Vaihtoehtoisesti voi myös kaksoisklikata tyhjää riviä. 

Kuittaus Valitse "Acknowledgement“-sarakkeen solu ja aktivoi valikosta toiminta “On activated“. 

Värit Merkitse “C Color“-sarakkeen solu ja valitse keltainen väri. Toista sama hälytystiloille
“CD", “CA" ja “CDA".

Vilkku Valitse “C flashing“-sarakkeen solu ja aktivoi valikosta "Flashing“.
“Display name” sarakkeessa anna tunnukseksi “P”.

-----------------------------------------------------------------------------------------------------

Ohje Vaihtoehtoisesti kaikki asettelut voidaan tehdä ominaisuusikkunassa 
Properties > State.

Sitä varten pitää valita uuden hälytysluokan rivi.
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Analogiahälytysten konfigurointi
Lisää sarakkeita hiiren oikealla painikkeella! 

Esimerkki Konfiguroidaan seuraavaksi analogiahälytys uuteen hälytysluokkaan “Prosessi” ja
toinen hälytys vakioluokkaan “Errors".

Avaa editori Avaa editori
Project Window > Alarm Management > Analog Messages

Lisää hälytys Merkitse tyhjä rivi ja käytä päämenun komentoa
Insert > New Object

Vaihtoehtoisesti voi myös kaksoisklikata tyhjää riviä.

Konfiguroi rivi Kirjoita kenttään “Text” hälytysteksti “Nopeus liian suuri” ja valitse hälytysluokaksi
“Errors".

Tag / Limit Valvotaan muuttujan “Ohjaus_nopeusoloarvo" raja-arvoa 1300 nousevalla reunalla
“Trigger mode > On rising edge”.

Toistetaan konfigurointi samoin askelin toiselle analogiahälytykselle: 
Prosessihälytys „Nopeus suuri“, raja-arvo 1250.
----------------------------------------------------------------------------------------------

Ohje Vaihtoehtoisesti kaikki asettelut voidaan tehdä hälytyksen ominaisuusikkunassa 
Properties Window

Sitä varten pitää osoittaa uuden hälytyksen rivi.

Hysteresis Hälytyskynnystä voi tasoittaa hystereesivalvonnalla.

Infotext   Tarvittaessa hälytykseen voi konfiguroida myös aputekstin, joka näytetään Runtime 
näytössä. 
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Bittihälytysten konfigurointi

PLC ohjelma:
U E0.2
= DB10.DBX1.0

Halutut hälytystekstit

E0.2 Säiliön pinta 1

Ohjauspaneelin hälytystekstilista:
1 Säiliön pinta 1
2 ….
Esim.  OP/TP Discrete Alarms

Esimerkki Konfiguroidaan bittihälytys, joka kertoo prosessisäiliöiden pinnan valvonnasta “Säiliön
1 pinta ylärajalla”. 

Avaa editori Avaa editori
Project Window > Alarm Management > Discrete Alarms

Lisää hälytys Merkitse tyhjä rivi ja käytä päämenun komentoa
Insert > New Object

Vaihtoehtoisesti voi myös kaksoisklikata tyhjää riviä.

Text Avaa hälytystekstin kirjoitusta varten ominaisuusikkunasta yleisasettelut:
Properties window > General. 

Settings/Text Kirjoita hälytysteksti: Säiliön_1_pinta  

Message class Koska pinnan ylärajasta halutaan hälytys, valitaan hälytysluokka “Errors". Tämän
luokan hälytykset pitää kuitata.

Trigger Tag Bittihälytykset osoitetaan hälytyssanoittain. Sanat voivat olla peräkkäin tai erillisiä
laitekohtaisia tilasanoja. Kuvan esimerkissä hälytykset kootaan muuttujaan 
“Hälytyssanat_PLC”. 
Tag: “Hälytyssanat_PLC” osoite DB10.DBW0.

Trigger Bit Valitse kentästä “Trigger Bit“ bitti 0. Tämä bitti liipaisee hälytyksen.

Number Huomaa, että bittihälytysten numerointi kasvaa automaattisesti.
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Hälytysnäytön konfigurointi

Alarm view Hälytysnäytössä esitetään hälytyspuskurissa olevat hälytykset. Näyttöön tuodaan
kaikkien hälytysluokkien hälytykset: Errors, Warnings, System ja PROSESSI.
(Esimerkkinä itse tehty luokka!). 
---------------------------------------------------------------------------------------

Menettelytapa Avaa Tools-työkaluikkuna ja lisää kuvaan “Ilmoitukset” hälytysnäyttö
Tools Window > Enhanced Objects > Alarm View.

General Määrittelyt tehdään ominaisuusikkunan "General“-välilehdellä.
Display Sisällöksi voi valita yhden vaihtoehdoista:
Alarms Näytetään hälytykset, mukaan lukien voimassaolevat (Pending)  ja kuittaamattomat

(Unacknowledged) hälytykset.
Alarm events Kaikki hälytyspuskurin ilmoitukset näkyvät, myös ohikulkevat systeemi-ilmoitukset (2 s).  

- Käytetään tätä harjoituksessa.
Alarm log Hälytysarkiston näyttö

Alarm classes Valitaan näyttöön halutut hälytysluokat “Errors, Warnings, System” ja “PROSESSI”.

Properties Properties –välilehdellä sovitetaan asettelut:
> Display Ota käyttöön kaikki vierityspalkit (scroll..) ja kuittauspainike „ACK“.
> Columns Valitse vähintään sarakkeet Time, Status, Alarm text ja Date.

Columns texts – Sarakkeille voi antaa nimet suomeksi.
Text across columns – hälytysteksti esitetään runtimessa toisella rivillä yli kaikkien 
sarakkeiden
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Hälytysten näyttö operointipaneelilla – Template

WinCC flexible tarjoaa hälytyksille seuraavat esitystavat operointipaneeleissa:
Alarm view
Message view Hälytysnäyttö konfiguroidaan tiettyyn projektikuvaan. Konfiguroidusta koosta riippuen, 

siinä voi esittää yhtäaikaisesti useita hälytyksiä. Eri hälytysluokille ja eri kuviin voidaan
projektoida useita hälytysnäyttöjä. 
Hälytysnäyttö voidaan projektoida myös vain yhden hälytysrivin kokokoiseksi.

Alarm window
Message window Hälytysikkuna konfiguroidaan kuvien “template”-pohjakuvaan ja se on siten osana

projektin kaikissa kuvissa. Projektoidusta koosta riippuen se voi näyttää yhtä aikaa
useita hälytyksiä. Hälytysikkunan voi sulkea ja avata tapahtumaohjatusti.

Alarm indicator
Message indicator Hälytysmerkki on konfiguroitava graafinen symboli, joka näytetään kuvassa, kun 

hälytys tulee. Hälytysmerkki on konfiguroitu kuvien “template”-pohjakuvaan ja se on 
siten osana projektin kaikissa kuvissa.

Hälytysmerkillä on kaksi tilaa: 

Vilkkuu: vähintään yksi kuittaamaton hälytys on odottamassa

Kiinteä: hälytykset on kuitattu, mutta vähintään yksi ei ole vielä lähtenyt.

Operointipaneelin tapahtumat voidaan konfiguroida tehtävälistalla.

Template WinCC flexible Wizardilla voi luoda nämä Template pohjan hälytysikkunat
automaattiasesti, kun perustetaan uusi projekti.
Ne voi lisätä myös myöhemmin, katso harjoitus ” Hälytysmerkin ja hälytysikkunoiden 
konfigurointi“.
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Hälytysmerkin ja hälytysikkunoiden konfigurointi (Template)

Hälytysmerkki Vilkkuva hälytysmerkki kertoo, että on tullut uusia hälytyksiä, jotka ovat vielä
kuittaamatta. Kiinteä hälytysmerkki kertoo, montako kuitattavaa hälytystä on edelleen
voimassa. Hälytysmerkkiin konfiguroidaan hälytysikkunoiden avaus. Jos hälytysmerkki
otetaan käyttöön, se on näkyvissä riippumatta näytössä olevasta kuvasta. 

Hälytysikkuna (1) Avaa “template”-pohjakuva ja lisää hälytysikkuna “Alarm window” Tools-
työkaluvalikosta. Anna hälytysikkunalle seuraavat ominaisuudet: 

General > Display >  Alarms > Unacknowledged... – kuittaamattomat
Properties > Layout: Mode Enhanced 

Display:         ACK-kuittauspainike (ei vierityspalkkeja)
Text: Tahoma, 8pt
Columns: otsikot (headings)
Misc: Name Anna nimeksi “Template_hälyikkuna”
Mode: Closable, Modal; Caption: otsikko: Kuittaamattomat hälyt

Hälytysikkuna (2) Lisää “template”-pohjakuvaan toinen hälytysikkuna (konfiguroitaessa ne voi sijoittaa
lomittain päällekkäin!) ja anna sille seuraavat ominaisuudet: 

General > Display >  Alarms > Pending alarms... - voimassa olevat
Unacknowledged... – kuittaamattomat

Properties > Layout: Mode Enhanced 
Display:         ACK-kuittauspainike (ei vierityspalkkeja)
Text: Tahoma, 8pt
Columns: otsikot (headings)
Misc: Name Anna nimeksi “Template_hälyikkuna2”
Mode: Closable, Modal; Caption: otsikko: Hälytysikkuna

Hälytysmerkki (3) Lisää Template-alueelle työkaluvalikosta „Alarm Indicator“-hälytysmerkki. 
Properties > Määrittele ominaisuusikkunan Events-sivulla tehtävät:
Vilkkuu Properties > Events > Click when flashing > ShowAlarmWindow > 

Template_hälyikkuna
Kiinteä Properties > Events > Click > ShowAlarmWindow > Template_hälyikkuna2.
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Systeemi-ilmoitusten näyttö

Systeemi-ilmoitukset Systeemi-ilmoitusten näyttöä varten voi Template-kuvaan konfiguroida oman ”Alarm
Window”-ikkunan. Ikkuna aukeaa, kun hälytys tulee, ja menee automaattisesti kiinni 
projektoidun näyttöajan jälkeen.

Näyttöaika Project > Alarms > Settings > Alarm Settings: System.. 
Display duration __( 2) sec

Ilmoitusikkuna Lisää “template”-pohjakuvaan hälytysikkuna ja anna sille seuraavat ominaisuudet: 
General > Display >  Alarms > Pending alarms - voimassa olevat

Alarm classes : System
Properties > Layout: Mode Enhanced 

Display:         ACK-kuittauspainike (ei vierityspalkkeja)
Text: Tahoma, 8pt
Columns: otsikot (headings)
Misc: Name Anna nimeksi “Template_hälyikkuna2”
Mode> Window: Automatic display, Closable, Resizaple; 

Caption: otsikko: Systeemi-ilmoitukset
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